龙芯开源社区

 找回密码
 注册新用户(newuser)
查看: 2469|回复: 8

[求助]libqt3-dev 3.3.7在哪儿?

[复制链接]
发表于 2007-1-9 16:06:14 | 显示全部楼层 |阅读模式
我要在盒子上编译qt3程序,可是仓库里的libqt3-dev是3.3.4的啊。
我又不想再重新编译一次qt,本来这个盒子编译就慢。
发表于 2007-1-9 16:21:38 | 显示全部楼层
libqt3-dev 3.3.7的 接口和3.3.4不一样么?
 楼主| 发表于 2007-1-9 16:25:20 | 显示全部楼层
一样啊。
可是如果我装3.3.4,就得降级系统里的qt,不然依赖关系不满足也不舒服。

我在fans给你发的pm看到了么?
发表于 2007-1-9 16:30:37 | 显示全部楼层
原来是runtime和dev不一致,强制把libqt3-dev 3.3.4装上,虽然有点不爽
等我去看看
发表于 2008-3-18 23:24:02 | 显示全部楼层
# apt-get install libqt3-dev
Reading package lists... Done
Building dependency tree... Done
Package libqt3-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  qt3-qtconfig qt3-linguist qt3-dev-tools-embedded qt3-dev-tools-compat qt3-dev-tools qt3-designer qt3-assistant
  qt3-apps-dev libqt3-mt-dev libqt3-headers libqt3-compat-headers
E: Package libqt3-dev has no installation candidate


# apt-get install libqt4-dev
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libqt4-dev: Depends: xlibmesa-gl-dev but it is not going to be installed or
                       libgl-dev
              Depends: libglu1-xorg-dev but it is not going to be installed or
                       libglu1-mesa-dev but it is not going to be installed or
                       libglu-dev
E: Broken packages
发表于 2008-3-18 23:25:14 | 显示全部楼层
apt-get install libqt3-mt-dev
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libqt3-mt-dev: Depends: libgl1-mesa-dev but it is not going to be installed or
                          libgl-dev
                 Depends: libglu1-mesa-dev but it is not going to be installed or
                          libglu-dev
E: Broken packages
发表于 2008-3-20 13:58:28 | 显示全部楼层
你喜欢玩的话,或许你需要升级你的debian到 lenny

loongson:~# aptitude show libqt3-mt-dev
Package: libqt3-mt-dev
State: installed
Automatically installed: yes
Version: 3:3.3.8b-4
Priority: optional
Section: libdevel
 楼主| 发表于 2008-3-20 19:35:45 | 显示全部楼层
呵呵,一年的贴子又出来了。
不过现在已经不用管这个了,正在从头编译。
发表于 2008-3-25 21:54:05 | 显示全部楼层
n0d,还是不拘泥发行版的好。

本版积分规则

Archiver|手机版|小黑屋|Lemote Inc.

GMT+8, 2021-1-17 14:01 , Processed in 0.178776 second(s), 15 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表