龙芯开源社区

 找回密码
 注册新用户(newuser)
查看: 4271|回复: 11

无法运行 apt-get update

[复制链接]
发表于 2009-1-11 16:41:34 | 显示全部楼层 |阅读模式
逸珑8089.

localhost:/# sudo apt-get update
E: 无法打开锁文件 /var/lib/apt/lists/lock - open (2 没有那个文件或目录)
E: 无法对状态列表目录加锁

我检查了一下, 发现 /var/lib/apt 指向 /home/var/lib/apt, 而 /home/var 这个目录不存在。
发表于 2009-1-11 17:17:48 | 显示全部楼层
手工创建就行了。
系统开发没经过什么测试就拿出来了。
 楼主| 发表于 2009-1-11 17:29:49 | 显示全部楼层
好像少很多呢, 我都要一个一个地建立吗?
 楼主| 发表于 2009-1-11 17:32:01 | 显示全部楼层
果然都一个一个建立了以后就可以了。
 楼主| 发表于 2009-1-11 17:49:46 | 显示全部楼层
正在读取软件包列表... 有错误!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: 无法解析或打开软件包的列表或是状态文件。


应该是 status 这个文件不对。 请问要怎么建立这个文件呢?
发表于 2009-1-12 08:35:14 | 显示全部楼层
麻烦有问题的朋友,看下设置 -> 系统信息 -> 系统版本
是不是1.1.0
还有,大家注意下磁盘空间的使用(df -h)
 楼主| 发表于 2009-1-12 09:41:36 | 显示全部楼层
发行版:  Lemote Lonux 1.1.0
磁盘空间貌似没有问题。
发表于 2009-1-12 09:54:05 | 显示全部楼层
为了兼顾SSD版本的空间,我们把VAR单独放在另一个地方了。

回头请开发人员放一个匹配的var到网上。
发表于 2009-1-12 09:55:41 | 显示全部楼层

回复 4# 的帖子

单单建立空文件是不够的,和系统已安装的状态不一致不行。
发表于 2009-1-12 10:57:08 | 显示全部楼层

本版积分规则

Archiver|手机版|小黑屋|Lemote Inc.

GMT+8, 2021-1-26 06:50 , Processed in 0.129263 second(s), 15 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表