龙芯开源社区

 找回密码
 注册新用户(newuser)
查看: 1359|回复: 3

在Ubuntu上交叉工具链4.8.3的编译链配置问题

[复制链接]
发表于 2016-1-12 21:22:38 | 显示全部楼层 |阅读模式
请问官网服务器上下载的4.8.3编译链能在Ubuntu64位上运行么,为什么我导入路径后查询版本一直提示二进制文件无法运行。。之前的编译器太老了,想换个最新的用。。
错误提示如下
root@yjjj-virtual-machine:/opt/gcc-4.8.3-1.loongson.3/bin# mips64el-redhat-linux-gcc -v
bash: /opt/gcc-4.8.3-1.loongson.3/bin/mips64el-redhat-linux-gcc: 无法执行二进制文件
root@yjjj-virtual-machine:/opt/gcc-4.8.3-1.loongson.3/bin# mips64el-redhat-linux-gcc-4.8.3 -v
bash: /opt/gcc-4.8.3-1.loongson.3/bin/mips64el-redhat-linux-gcc-4.8.3: 无法执行二进制文件
root@yjjj-virtual-machine:/home/yjjj# mips64el-linux-gcc -v
mips64el-linux-gcc:未找到命令
root@yjjj-virtual-machine:/home/yjjj# gcc -v
bash: /opt/gcc-4.8.3-1.loongson.3/bin/gcc: 无法执行二进制文件

下载的编译链链接如下
http://ftp.loongnix.org/toolchai ... oongson.3-centos64/
发表于 2016-1-13 11:11:46 | 显示全部楼层
这个应该是在龙芯机器上用的。
 楼主| 发表于 2016-1-13 15:28:26 来自手机 | 显示全部楼层
冲天飞豹 发表于 2016-1-13 11:11
这个应该是在龙芯机器上用的。

那其他机子上能用的是哪些
发表于 2016-1-13 16:13:29 | 显示全部楼层

本版积分规则

小黑屋|手机版|Archiver|Lemote Inc.  

GMT+8, 2019-9-23 04:13 , Processed in 0.185313 second(s), 19 queries .

快速回复 返回顶部 返回列表