龙芯开源社区

 找回密码
 注册新用户(newuser)
查看: 6474|回复: 16

求debian6 直接 tar 安装的详细操作流程

  [复制链接]
发表于 2011-7-13 13:08:42 | 显示全部楼层 |阅读模式
根据 电话联系wangyulong@loongson.cn,解决 debian6的问题,

http://debian.printk.org/download/liwengang/debian6.tar.gz

直接tar 到硬盘安装(/dev/hda2), ext3),解压完成后,无法启动,没有选项,

请问详细的操作流程,

谢谢
发表于 2011-7-13 21:32:28 | 显示全部楼层
回复 1# bywetech


    vim /boot/boot.cfg
照着添加一条就可以了,当然要改下你的debian 的安装所在分区 和 内核 等信息就好了
 楼主| 发表于 2011-7-13 23:22:22 | 显示全部楼层
回复 2# mxcai2005


    timeout 3
default 0
showmenu 1
title RedFlag
        kernel /dev/fs/ext2@wd0/boot/vmlinuz-2.6.27.7-43
        args console=tty2 no_auto_cmd root=/dev/hda1 uca=0x50000000,0x1000000

这个信息是我添加的,还是没有反应,选择debian6 后,就是黑屏,没有任何反应,

title debian6
        kernel /dev/fs/ext2@wd0/mnt/hda2/boot/vmlinux-2.6.32-5-4kc-malta
        args console=tty2 no_auto_cmd root=/dev/hda2 uca=0x50000000,0x1000000


请问应该如何设定?
发表于 2011-7-14 10:53:41 | 显示全部楼层
试试这个:
title debian6
        kernel /dev/fs/ext2@wd0/boot/vmlinux-2.6.32-5-4kc-malta
        args console=tty2 no_auto_cmd root=/dev/hda2 uca=0x50000000,0x1000000
发表于 2011-7-14 10:57:19 | 显示全部楼层
title debian6
        kernel /dev/fs/ext2@wd1/boot/vmlinux-2.6.32-5-4kc-malta
        args console=tty2 no_auto_cmd root=/dev/hda2 uca=0x50000000,0x1000000
发表于 2011-7-14 17:02:37 | 显示全部楼层
新内核不认“hd?”的硬盘表示方式吧
 楼主| 发表于 2011-7-14 22:03:39 | 显示全部楼层
本帖最后由 bywetech 于 2011-7-14 22:53 编辑

苦苦测试了整整2天两夜,2f6004盒子启动了无数次,第一个系统是红旗RFlinux,第二个分区和系统是debian6,

通过以上方式,hda的 硬盘表示没有启动,(我还在郁闷呢,为什么debian 的 系列全是 sda 表示分区? 而红旗RFlinux则把 磁盘分区为hda,移动硬盘为sda, u盘/sd卡模认为 sdb)
通过u盘上的 vmlinux.2f启动成功,但是 仅仅 进入 shell界面,用户名:root,密码:root。(u盘为 红旗RFlinux安装用)
(pmon>   load /dev/fs/ext2@usb0/boot/vmlinux.2f
pmon> g args console=tty root=/dev/hda2  timedelay=10 fastboot )

可以进入到终端(bash,shell),用户名:root, 密码: root,


希望可以安装双系统, 实在 不行, 安装一个 debian6, 一个分区160G也可以,
不希望,再也不希望用 bjlx.org.cn的 debian6了... ...

希望 更多的 爱好者 帮忙解决, 谢谢!
!!!
 楼主| 发表于 2011-7-15 01:24:06 | 显示全部楼层
本帖最后由 bywetech 于 2011-7-15 01:32 编辑

回复 7# xu_gong


    附件为 bjlx.org.cn发行的 debian6, 20110517版 的 /boot/boot.cfg, 经过多次 测试, 更改,

尽管你添加或者 改动, 保存后, boot.cfg仍然执行最初的设定值,不知如何是好啊 ?

这个系统的分区 倒是 sda, 可是boot.cfg 无法更改啊?

最后 测试 把 boot.cfg中 的 信息 全部 删除,然后保存,然后重启, 系统依然如初,还是4个选项,厉害,求更改的方法?

求帮助!!

谢谢!

附件1:


default 0
timeout 3
showmenu 1

title        debian6
kernel        (wd0,0)/vmlinux
args        console=tty root=/dev/sda2 console=tty no_auto_cmd resume=/dev/sda3 usbcore.autosuspend=1 libata.force=80c quiet


title        android 1.5 demo
kernel        (wd0,0)/android
args        console=tty loglevel=0 androidboot.hardware=yl2f no_auto_cmd
initrd        (wd0,0)/initrd.img

title        usb
kernel        (usb0,0)/vmlinux-2.6.32-5-4kc-malta
args        console=tty root=/dev/sda7 console=tty no_auto_cmd

#   machtype=     "lemote-fuloong-2e-box",
#      "lemote-fuloong-2f-box",
#      "lemote-mengloong-2f-7inches",
#      "lemote-yeeloong-2f-8.9inches",
#      "dexxon-gidum-2f-10inches",
#      "lemote-nas-2f",
#      "lemote-lynloong-2f",



### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the update-pmon script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/sda2 no_auto_cmd resume=/dev/sda3 usbcore.autosuspend=1 libata.force=80c quiet

## ## End Default Options ##

title                Debian GNU/Linux (2.6.38-loongson-2f)
kernel                (wd0,0)/boot/vmlinux-2.6.32-5-4kc-malta
args                console=tty root=/dev/sda7 no_auto_cmd resume=/dev/sda3 usbcore.autosuspend=1 libata.force=80c quiet

### END AUTOMAGIC KERNELS LIST ##
发表于 2011-7-15 08:23:40 | 显示全部楼层
pmon默认是加载sda1 里的boot.cfg,建议修改sda1里的boot.cfg,机器自带的系统我没有用过,可能sda1使用了只读挂载,你可以用维护盘来改,或者找一下怎么取消只读挂载,然后再修改boot.cfg。
发表于 2011-7-15 08:57:03 | 显示全部楼层
本帖最后由 mxcai2005 于 2011-7-15 09:02 编辑

回复 3# bywetech


    title debian6
        kernel /dev/fs/ext2@wd0/mnt/hda2/boot/vmlinux-2.6.32-5-4kc-malta
        args console=tty2 no_auto_cmd root=/dev/hda2
这个主要是指定的内核位置不对(你这样仍是在第一个分区里面找内核)
改为
title debian6
        kernel /dev/fs/ext2@wd0b/mnt/hda2/boot/vmlinux-2.6.32-5-4kc-malta
        args console=tty2 no_auto_cmd root=/dev/hda2

本版积分规则

小黑屋|手机版|Archiver|Lemote Inc.  

GMT+8, 2019-1-22 14:22 , Processed in 0.185205 second(s), 17 queries .

快速回复 返回顶部 返回列表