龙芯开源社区

 找回密码
 注册新用户(newuser)
查看: 6854|回复: 2

gdb problem on Gentoo n32

  [复制链接]
发表于 2009-4-3 00:07:31 | 显示全部楼层 |阅读模式
Hello,

I'm using Gentoo n32 (from r0bertz) and I got the following problem with gdb :

xiwen ~ (n32) # gdb /bin/ls
GNU gdb 6.8
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "mips64el-unknown-linux-gnu"...
(no debugging symbols found)
(gdb) run
Starting program: /bin/ls
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
Error while reading shared library symbols:
find_new_threads_callback: cannot get thread info: generic error
find_new_threads_callback: cannot get thread info: generic error

Any ideas of what is going wrong ?
http://www.lemote.com/bbs/viewthread.php?tid=20325

I have seen this post without answer :

Cheers
Erwan
发表于 2009-4-3 19:18:56 | 显示全部楼层
i happen to know a workaround, use this to start gdb:
strace -o /dev/null -f gdb
发表于 2009-8-28 00:44:07 | 显示全部楼层
just a reminder, this problems is already solved in glibc-2.10.1
and glibc-2.10.1 is in my overlay

本版积分规则

小黑屋|手机版|Archiver|Lemote Inc.  

GMT+8, 2019-1-21 22:14 , Processed in 0.188573 second(s), 21 queries .

快速回复 返回顶部 返回列表