qiup 发表于 2016-2-19 10:57:06

中标麒麟V6.2-32bit+龙芯3A平台只能用gcc4.5.1吗?没有更高的版本了吗?

本帖最后由 qiup 于 2016-2-19 11:21 编辑

如题,有大量代码用到了C++11新特性,现在需要移植到中标麒麟V6.2-32bit+龙芯3A平台上。发现自带的是gcc-32bit v4.5.1,该版本不支持C++11。
然而,尝试使用ftp.loongnix.org/toolchain的gcc版本,还不知道会不会有问题?【fedora13和centos下的gcc不知道能不能直接用在中标麒麟下面】
方法二,本地编译一个gcc的高版本?
方法三,重构源代码,增加c++11特性宏?[工作量较大]

heiher 发表于 2016-2-19 12:40:09

是时候换个新系统了吧。

qiup 发表于 2016-2-19 13:53:20

heiher 发表于 2016-2-19 12:40
是时候换个新系统了吧。

问题的关键是不,能,换!

heiher 发表于 2016-2-19 16:06:47

qiup 发表于 2016-2-19 13:53
问题的关键是不,能,换!

哦。

华中科大一学生 发表于 2016-2-20 11:39:40

是时候打倒肿膘麒麟了吧。

无产者 发表于 2016-4-4 16:16:51

qiup 发表于 2016-2-19 13:53
问题的关键是不,能,换!

有什么不能换的?数据一备份还不是分分钟换?难道您有恋垃圾癖?

无产者 发表于 2016-4-4 16:17:55

换loongnix,问题立刻解决。

luoxiao95 发表于 2016-4-6 20:08:10

斯托曼发现你在使用中标麒麟,呵呵笑了两下。
乔布斯发现你在使用中标麒麟,无语摇了摇头。
林纳斯发现你在使用中标麒麟,大骂一声“Fuck you!”
;P;P;P
页: [1]
查看完整版本: 中标麒麟V6.2-32bit+龙芯3A平台只能用gcc4.5.1吗?没有更高的版本了吗?